Web hosting expired

Incident Report for Bloxycraft Status

Update

Because the free web host expired
Posted Mar 19, 2024 - 15:34 UTC

Investigating

I have decided to stop hosting this website since it wasn't really useful.
Posted Mar 19, 2024 - 15:33 UTC
This incident affects: You Are An Idiot Video.